nixos/modules/vms.nix
Jake Hillion 9b8fd11726
Some checks failed
flake / flake (push) Failing after 42s
vms: add support for nix configured virtual machines
2024-04-11 08:57:40 +01:00

22 lines
462 B
Nix

{ config, lib, ... }:
{
options = {
boot.isVirtualMachine = lib.mkOption {
type = lib.types.bool;
default = false;
description = lib.mdDoc ''
Whether this NixOS machine is a virtual machine running in another NixOS system.
'';
};
virtualMachines = lib.mkOption {
type = lib.types.attrsOf
(lib.types.submodule (
{ config, options, name, ... }:
{ }
))
};
};
}