nixos/modules/home/git.nix
Jake Hillion c31106951b
All checks were successful
continuous-integration/drone/pr Build is passing
continuous-integration/drone/push Build is passing
git: ship .gitconfig
2023-01-21 20:08:14 +00:00

23 lines
381 B
Nix

{ pkgs, lib, config, ... }:
{
home-manager.users.jake.programs.git = {
enable = true;
extraConfig = {
user = {
email = "jake@hillion.co.uk";
name = "Jake Hillion";
};
pull = {
rebase = true;
};
merge = {
conflictstyle = "diff3";
};
init = {
defaultBranch = "main";
};
};
};
}