nixos/pkgs/storj.nix
Jake Hillion 3295b20277
All checks were successful
continuous-integration/drone/pr Build is passing
continuous-integration/drone/push Build is passing
tywin: storj: enable on d2
2023-07-31 10:47:15 +01:00

34 lines
898 B
Nix

{ stdenv, lib, fetchFromGitea, buildGoModule, ... }:
let
version = "1.82.1";
src = fetchFromGitea {
domain = "gitea.hillion.co.uk";
owner = "JakeHillion";
repo = "storj";
rev = "f75ec5ba34b2ccce005ebdb6fae697e0224998d9";
hash = "sha256-zUpzkdiAbE10fq1KDXEarPURqByD8JV0NkQ9iNxPlWI=";
};
meta = with lib; {
description = "Storj is building a distributed cloud storage network.";
homepage = "https://github.com/storj/storj";
license = licenses.agpl3Only;
maintainers = [{
email = "jake@hillion.co.uk";
matrix = "@jake:hillion.co.uk";
name = "Jake Hillion";
github = "JakeHillion";
githubId = 5712856;
}];
};
in
buildGoModule rec {
pname = "storagenode";
inherit version src meta;
vendorHash = "sha256-Q9+uwFmPrffvQGT9dHxf0ilCcDeVhUxrJETsngwZUXA=";
subPackages = [
"cmd/storagenode"
"cmd/identity"
];
}