nixos/modules/services/tang.nix
Jake Hillion cde6bdd498
All checks were successful
flake / flake (push) Successful in 1m13s
tywin: enable clevis/tang for boot
2024-06-10 22:34:28 +01:00

21 lines
334 B
Nix

{ config, pkgs, lib, ... }:
let
cfg = config.custom.services.tang;
in
{
options.custom.services.tang = {
enable = lib.mkEnableOption "tang";
};
config = lib.mkIf cfg.enable {
services.tang = {
enable = true;
ipAddressAllow = [
"138.201.252.214/32"
"10.64.50.20/32"
];
};
};
}