73 lines
2.2 KiB
Nix
73 lines
2.2 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-amd" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{
|
||
device = "tmpfs";
|
||
fsType = "tmpfs";
|
||
options = [ "mode=0755" "size=100%" ];
|
||
};
|
||
|
||
fileSystems."/boot" =
|
||
{
|
||
device = "/dev/disk/by-uuid/ED9C-4ABC";
|
||
fsType = "vfat";
|
||
options = [ "fmask=0022" "dmask=0022" ];
|
||
};
|
||
|
||
fileSystems."/data" =
|
||
{
|
||
device = "/dev/disk/by-uuid/9aebe351-156a-4aa0-9a97-f09b01ac23ad";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=data" ];
|
||
};
|
||
|
||
fileSystems."/cache" =
|
||
{
|
||
device = "/dev/disk/by-uuid/9aebe351-156a-4aa0-9a97-f09b01ac23ad";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=cache" ];
|
||
};
|
||
|
||
fileSystems."/nix" =
|
||
{
|
||
device = "/dev/disk/by-uuid/9aebe351-156a-4aa0-9a97-f09b01ac23ad";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=nix" ];
|
||
};
|
||
|
||
boot.initrd.luks.devices."disk0-crypt" = {
|
||
device = "/dev/disk/by-uuid/a68ead16-1bdc-4d26-9e55-62c2be11ceee";
|
||
allowDiscards = true;
|
||
};
|
||
boot.initrd.luks.devices."disk1-crypt" = {
|
||
device = "/dev/disk/by-uuid/19bde205-bee4-430d-a4c1-52d635a23963";
|
||
allowDiscards = true;
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp6s0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|